WordPress+Flutter开发APP教程:5.安装依赖包

说明

关于依赖包我已经在小节:WordPress+Flutter开发APP教程:4.pubspec.yaml 中说明了,本小节将带领大家安装第一个依赖包。

开始

定位 pubspec.yaml 文件位置:

这里我们需要安装的依赖包是:Dio :依赖包位置

打开依赖包页面之后,点击复制图标即可将依赖包名称已经版本号复制到剪贴板:

复制结果:dio: ^4.0.6

粘贴至我们定位到的 pubspec.yaml 文件位置

之后点击右上角的按钮:Pub get

点击之后即开始下载依赖包,下载完成之后就可以在项目中引用拉。

结尾

  1. 复制的时候注意格式(依赖包名称:版本号)
  2. 粘贴的时候注意空格
  3. 如果右上角没有出现 pub get 即表示你很可能没有正确安装好flutter开发环境
  4. Dio:是一个flutter中很强大的HTTP请求库,网上有很多并且很详细的教程,这里就不再细讲了,但是在项目后续开发过程中会提到。

目录

  1. 说明
  2. 创建项目,并运行
  3. 项目目录结构
    1. pubspec.yaml
      1. 安装依赖包
  4. 安装项目依赖
  5. 操刀main.dart
  6. 认识mian.dart
  7. 初识MaterialApp
  8. 引入状态管理器Get
  9. 创建首页
  10. 初始化依赖包 flutter_screenutil
  11. 认识Scaffold

源码仓库地址:https://gitee.com/sliver-ring/sliver-wp-flutter

给TA打赏
共{{data.count}}人
人已打赏
APP开发

WordPress+Flutter开发APP教程:4.pubspec.yaml

2022-6-7 13:26:59

APP开发

WordPress+Flutter开发APP教程:6.安装项目依赖

2022-6-7 14:02:17

0 条回复 A文章作者 M管理员
    暂无讨论,说说你的看法吧
个人中心
今日签到
有新私信 私信列表
搜索